Firmwareupdate Deye...
 
Benachrichtigungen
Alles löschen

[Geschlossen] Firmwareupdate Deye SUN-12K-SG04LP3-EU selber durchführen Anleitung mit FW-Dateien - alt

954 Beiträge
186 Benutzer
248 Reactions
69.6 K Ansichten
(@larado)
Vorsichtiger Stromfühler
Beigetreten: Vor 2 Jahren
Beiträge: 30
 

Danke für die Infos. Meine Neugier war größer als das Risiko und ich habs mal durchlaufen lassen.

Habe ebenfalls einen SUN-12K-SG04LP3.

Der ganze Vorgang dauert ca. 30 Minuten und am Ende funktionierte bei mir weiterhin alles einwandfrei.

Es sei anzumerken, daß zum Schluß des zweiten Updates der LOAD Ausgang deaktiviert wird. Solltet Ihr dort systemrelevante Geräte dran haben, dann seht vorher zu, daß die aus oder am Netz angeschlossen sind.

Jetzt müsste Deye nur noch die Files im Netz zur Verfügung stellen. Mir ist nach wie vor nicht wohl bei der Idee, daß mein Wechselrichter aus dem Netz erreicht werden könnte, wenn ich den durch die Firewall lassen würde. Von daher mache ich diese Updates sehr gerne selbst.


   
Pucky08-15, jgatringer, Schukostecker and 1 people reacted
Schlagwörter für Thema
Sol@r_Joker
(@solar_joker)
Batterielecker
Beigetreten: Vor 2 Jahren
Beiträge: 309
Themenstarter  

Veröffentlicht von: @larado

Es sei anzumerken, daß zum Schluß des zweiten Updates der LOAD Ausgang deaktiviert wird. Solltet Ihr dort systemrelevante Geräte dran haben, dann seht vorher zu, daß die aus oder am Netz angeschlossen sind.

Nice to know! Da meiner bisher nur am Akku und seit gestern am ersten String hängt, konnte ich das nicht bemerken. Werde es oben mit aufnehmen. Danke also @larado

 

Balkon-Solar mit AP-Systems QS1
DIY-Dach-PV - komplette Eigeninstallation & -anmeldung
DIY-Stromspeicher (11kw mit 230A CALB LiFePo4 + [in Arbeit] 16 KW mit 280A EVE in)
Deye SUN-12k: Läuft seit Oktober 2023


   
(@kawavali)
Vorsichtiger Stromfühler
Beigetreten: Vor 1 Jahr
Beiträge: 8
 

Hat das schon einer an einem 10k getestet? Lässt sich der Load Ausgang dann wieder ohne Probleme aktivieren?


   
(@tobimer)
Newbie
Beigetreten: Vor 12 Monaten
Beiträge: 2
 

Ne, ich habe gestern meinen 12K geupdated… er hat meinen Rosen-Speicher nicht erkannt. Das Update lief wie beschrieben problemlos. Der Neustart nach der 2. Datei hat etwas gedauert. Aber voller Erfolg, jetzt kommuniziert er mit dem  BMS. 
Grüße Tobias


   
(@locutus)
Vorsichtiger Stromfühler
Beigetreten: Vor 1 Jahr
Beiträge: 9
 

Habs bei mir auch am SUN-12K-SG04LP3 durchlaufen lassen ohne Probleme.

 

"Nur" nachdem das MCU1-Update durch war, hat er mein Seplos-BMS via RS485 nicht mehr erkannt. Dadurch Kommunikationsfehler und je nach Einstellung werden gewisse Sachen deaktiviert.

Nachdem das MCU2-Update durch war lief alles wie vorher. Beim nächsten mal werde ich die Batterie vorher auf Spannungsgeführt umschalten und später wieder auf RS485.


   
(@auric)
Heroischer Stromgenerator
Beigetreten: Vor 2 Jahren
Beiträge: 1774
 

Also eine Inselanlage am Polarkreis im Winter, die muss mit verbundener Batterie geupdated werden, aber ansonsten kann man das BMS für das Update doch abschalten oder?


   
(@christoph83)
Vorsichtiger Stromfühler
Beigetreten: Vor 1 Jahr
Beiträge: 14
 

bei meinem 8K hat es heute auch ohne Probleme funktioniert.

Nur gab es nach dem MCU2 update keinen Reboot, sondern nur wie beschrieben einen cutoff des Load Ausgang und die Display Visualisierung des Stromflusses hat dann ein paar Sekunden gebraucht, bis wieder Pfeile vorhanden waren.

Und noch was, die Axxx und Bxxx sind keine Fehlercodes meiner Meinung, sondern die Adressblöcke die beschrieben werden.

Bei dem MCU2 file lief es bis B254 hoch


   
(@totti1001)
Batterielecker
Beigetreten: Vor 2 Jahren
Beiträge: 324
 

8K-SG04LP3 schon mehrfach selbst ohne Probleme geflasht, hatte den Support damals extra gefragt ob die Dateien für alle SG04LP3 sind und das haben sie mir bestätigt.

Was man mir aber auch schrieb, HMI (MCU1) und Main (MCU2) sollten auch zusammen passen. Ab 1128 ist es wohl die C037, wobei ich beim ersten Update auf die 1128 auch noch C031 hatte und die C037 separat bekam.

Jetzt wär ne Firmware Sammlung schön.

Und übrigens: Ganz tolle Arbeit @Solr_Joker !!


   
Paule1334, Treptau, g3vara and 1 people reacted
Sol@r_Joker
(@solar_joker)
Batterielecker
Beigetreten: Vor 2 Jahren
Beiträge: 309
Themenstarter  

Veröffentlicht von: @totti1001

Und übrigens: Ganz tolle Arbeit @Solr_Joker !!

 

Vielen Dank!

Schön, dass es euch hilft und den Deye-Support entlastet Smile

 

Balkon-Solar mit AP-Systems QS1
DIY-Dach-PV - komplette Eigeninstallation & -anmeldung
DIY-Stromspeicher (11kw mit 230A CALB LiFePo4 + [in Arbeit] 16 KW mit 280A EVE in)
Deye SUN-12k: Läuft seit Oktober 2023


   
Maila02, g3vara and Totti1001 reacted
(@gg0815)
Vorsichtiger Stromfühler
Beigetreten: Vor 12 Monaten
Beiträge: 5
 

Veröffentlicht von: @larado

Es sei anzumerken, daß zum Schluß des zweiten Updates der LOAD Ausgang deaktiviert wird. Solltet Ihr dort systemrelevante Geräte dran haben, dann seht vorher zu, daß die aus oder am Netz angeschlossen sind.

Hallo,

Bedeutet dies das zwei der wichtigsten beworbenen Features dieser Geräteserie, die Offgridfähigkeit und die Notstromversorgung, durch diese Firmeware verloren gehen ?

Gunnar

 


   
(@auric)
Heroischer Stromgenerator
Beigetreten: Vor 2 Jahren
Beiträge: 1774
 

Ja richtig, für ein paar Sekunden gibt es keine Notstromversorgung 😆 


   
(@gg0815)
Vorsichtiger Stromfühler
Beigetreten: Vor 12 Monaten
Beiträge: 5
 

@auric ok dann hab ich das wohl missverstanden. und nach dem firmwareupdate ist das alles wieder verfügbar ?

Danke Gunnar


   
(@auric)
Heroischer Stromgenerator
Beigetreten: Vor 2 Jahren
Beiträge: 1774
 

natürlich ist alles wieder verfügbar.


   
(@bernd-p)
Vorsichtiger Stromfühler
Beigetreten: Vor 1 Jahr
Beiträge: 10
 

Deye SUN-12K-SG04LP3-EU Update 

Diese Infos findet Ihr im WR-Menü (Enter->Device Info).

Bei mir waren vorher diese Versionen drauf: Ver 2005-1128-1807

 

Update, Ver 2005-1131-1807 wie beschrieben erfolgreich aufgespielt, jetzt geht er nicht mehr auf on! kein PV Strom....

Fehlermeldung F31: Slave_Contactor_Fault  .....und jetzt weiss ich auch nicht mehr.


   
Pau reacted
(@huettnanlage)
Newbie
Beigetreten: Vor 11 Monaten
Beiträge: 1
 

@bernd-p die Fehlermeldung hatte ich auch schon des Öfteren, einfach mal bisschen probieren. Vor dem FW Update wollte er unbedingt eine Batterie vorgegaukelt haben, dann ging es wieder, Lade und Entladestrom kann auf 0A.

Nach dem Update geht es auch auf No Bat, mit der Besonderheit, dass er mit Batterie auch noch 10 W Gleichstrom zum Laden aus den Panels zieht und bei No Bat halt abschaltet, da vermutlich unterm Strich das Wechselrichten mehr Strom verbraucht.

Das Update beim 8K hat ohne Probleme funktioniert, vielen Dank für den wertvollen Beitrag!


   
Seite 1 / 64
Firmwareupdate Deye...
 
Teilen: