Benachrichtigungen
Alles löschen

JKBMS auslesen über BLE (Bluetooth) oder RS485 Adapter mittels EPS, ioBroker

729 Beiträge
163 Benutzer
16 Likes
131.2 K Ansichten
(@luigi)
Vorsichtiger Stromfühler
Beigetreten: Vor 4 Jahren
Beiträge: 83
 

@pharadeo 

Alles wird über BT gemacht. Bitte dem link folgen nachlesen... ich hab versucht dass alles komplett zusammen zu schreiben....

Die Schalter sind aktiv. Welche dann über iobroker schaltbar sind. 


   
AntwortZitat
(@luigi)
Vorsichtiger Stromfühler
Beigetreten: Vor 4 Jahren
Beiträge: 83
 

@pharadeo 

Moin, alles kann und wird über die BT Schnittstelle gemacht. 

Bitte dem Link folgen, da hab ich versucht auch alles zusammen schreiben was wichtig ist.   


   
AntwortZitat
(@andi_pad)
Vorsichtiger Stromfühler
Beigetreten: Vor 2 Jahren
Beiträge: 19
 

Ich lese meinen JKBMS seit ca. 2-3 Monaten auch über BT aus. Die Kopplung erfolgt zu einem Raspi mit Venus OS , der Abstand beträgt ca. 30cm. Die Werte werden vom Venus OS an einen weiteren Raspi mit IOBroker/InfluxDB zur Weiterverarbeitung weitergereicht. Die RS485 Verbindung vom JKBMS an den Raspi mit Venus OS funktioniert leider nicht.

Ich stelle aber immer wieder fest, dass die beiden Akkutemperaturen in Venus OS mit 100°C angezeigt werden. Ein Neustart des Raspi bringt dann öfters eine Abhilfe. Hat eventuell noch jemand solche Erfahrungen, dass die Temperaturwerte über BT nicht korrekt weitergegeben werden? Die Temperaturanzeige über die BT-Verbindung zur JKBMS Android Software zeigt korrekte Akkutemperaturen.


   
AntwortZitat
(@luigi)
Vorsichtiger Stromfühler
Beigetreten: Vor 4 Jahren
Beiträge: 83
 

@andi_pad 

beim Cerbo (Venus) hole ich die Daten über RS485  GitHub - Louisvdw/dbus-serialbattery: Battery Monitor driver for serial battery in VenusOS GX systems

 

 

das hab ich vor mehr als 6 Monaten eingerichtet,... läuft....

 

ich sehe gerade, daß Louisvdw es auch hin bekommen hat mittles BT das JK auszulesen... (vermutlich machst du das mit deinem Raspi(Venus)

 

Aber de BT to iobroker war sehr insabil mit den hier angebotenen 3.4   3.6.. Versionen vom Threadstarter  

Diese r Beitrag wurde geändert Vor 3 Monaten 3 mal von Luigi.

   
AntwortZitat
(@kthemall)
Vorsichtiger Stromfühler
Beigetreten: Vor 2 Jahren
Beiträge: 25
 

hi, ich hätte heute die v3.4 und die v3.6 mit meinem B6A24S10P versucht zum laufen zu bringen, leider liefert er nur wirres zeug. mit der 1.1 und dem

constbool protocol_32 = true 
parameter läuft es bis auf die balance_current werte. die stimmen zwar im positiven bereich im negativen bereich allerdings wird immer eine 3 an der einerstelle angezeigt obwohl das bms max 0,6a leistet
ist das irgendwie bekannt?
 
LG Tom
 

   
AntwortZitat
(@sunny198828)
Newbie
Beigetreten: Vor 8 Monaten
Beiträge: 1
 

Ich habe jetzt die Version 3.6 mal ein bisschen erweitert.

Bei dem negativen Balancer Strom habe ich jetzt 2 dazu gerechnet. Kommt der app am nahesten ... obs richtig stimmt kann ich nicht sagen.

Es müssen in den einstellungen jetzt die BMS version angegeben werden und wie viele Zellen angeschlossen sind.

Nun arbeite ich daran die Daten auch per Json zu senden.

Klappt alles wunderbar bis jetzt.

Das hier ist mein BMS

 

edit: Json ausgabe funktioniert jetzt auch.

diese kann mittels "BMS_MQTT_Name"/parameter/MQTT_json  true/false ein und ausgeschaltet werden.

Version habe ich auf 3.7 geändert.

Mit freundlichen Grüßen

Diese r Beitrag wurde geändert Vor 3 Monaten 7 mal von sunny198828

   
AntwortZitat
(@luigi)
Vorsichtiger Stromfühler
Beigetreten: Vor 4 Jahren
Beiträge: 83
 

Ich bin nun voll beim ESP Home gelandet.

Und noch 16 Dallas DS18B20 Temperatur Sensoren mit eingepflegt. (Jede Batt Zelle wird dann mit überwacht) Für meine Bedürfnisse voll genial... Daten gehen dann an IOBroker per MQTT raus. 

 

Das ist nur das Web Interface, womit ich dann auf dem ESP drauf bin....


   
AntwortZitat
(@postmortal)
Vorsichtiger Stromfühler
Beigetreten: Vor 1 Jahr
Beiträge: 9
 

Hallo, ich habe ein Problem.

Ich wollte auf die Version 3.7 updaten, da ih mir die 3.6 zerschossen habe und nicht mehr hinbekam.

Leider bekomme ich beim kompilieren immer die Meldung "Sketch zu groß. Der Sketch verwendet 1573197 Bytes (120%) des Programmspeicherplatzes. Das Maximum sind 1310720 Bytes"

Ich verwende einen ESP32 Wroom von AZDelivery. Kann mir jemand helfen?


   
AntwortZitat
 at21
(@at21)
Newbie
Beigetreten: Vor 1 Jahr
Beiträge: 1
 

@rabe04 darf ich dich fragen wo ich die richtige protocol version einstelle? Hab den gleichen Fehler.lg


   
AntwortZitat
Seite 49 / 49
Teilen: