Benachrichtigungen
Alles löschen

Victron Multiplus II ESS Anzeigeproblem

15 Beiträge
4 Benutzer
0 Reactions
2,755 Ansichten
(@zwiebacksaege)
Vorsichtiger Stromfühler
Beigetreten: Vor 2 Jahren
Beiträge: 88
Themenstarter  

Moin Leute,

nachdem ich nun endlich einen Akku an Land ziehen konnte habe ich mein Multiplus gestern in Betrieb nehmen können. Nun habe ich aber folgendes Problem oder zumindest Verständnisproblem:

- Ich habe die PV Anlage auf ACout1 um schwarzstartfähig zu sein und die WR auch im Bedarfsfall runterregeln zu können. Dem ESS des MP habe ich das auch so "mitgeteilt".
- Für die Leistungsmessung der PV-WR nutze ich einen Shelly, der über das bekannte Skript im Venus als PV angezeigt wird.
- EM24 misst direkt am Hausanschluss.

Das hat bisher ohne MP2 auch super funktioniert. Es wurden also die Ertragswerte der PV richtig mit dem Verbrauch des EM24 verrechnet.

Mit MP2 und Akku liest sich der Energiefluss jetzt aber seltsam. Es sieht so aus, als würde die PV Anlage auf der Last-Seite gezählt werden, also als Verbraucher. Mach ich da was grundsätzlich falsch? Oder wird die Akku-Ladung mit in die AC-Lasten eingerechnet?


   
Zitat
saugnapf
(@saugnapf)
Heroischer Stromgenerator
Beigetreten: Vor 2 Jahren
Beiträge: 1284
 

Meinst du die Anzeige in der Remote Console?
Vielleicht kannst du einen screenshot schicken, von dem, was du meinst?

Bei mir schaut das bei ähnlicher Konfiguration so aus:

6x 300Wp = 1.8kWp an 3x EVT560 MicroInverter - MultiPlus-II GX mit 4x PylonTech US2000 (je 2,4kWh)

Hier klicken, wenn du Kollegen in deiner Umgebung finden möchtest.


   
AntwortZitat
(@zwiebacksaege)
Vorsichtiger Stromfühler
Beigetreten: Vor 2 Jahren
Beiträge: 88
Themenstarter  

genau so siehts bei mir auch aus...
nur bei Dir passen die Zahlen zusammen: Akku-Ladung+AC-Last-Netz = PV
das passt bei mir nicht.

aber Asche auf mein Haupt: ich denke es liegt daran, dass ich für den Shelly-PV-Plugin die falsche Phase übergeben habe. Bzw. habe ich beim Verkabeln die Phase nochmal gewechselt und im Plugin nicht aktualisiert.
Ich schätze, dass er damit dann beim rechnen zwangsläufig falsch summiert.


   
AntwortZitat
(@zwiebacksaege)
Vorsichtiger Stromfühler
Beigetreten: Vor 2 Jahren
Beiträge: 88
Themenstarter  

es geht leider auch mit der korrekten Phaseneinstellung nicht mehr :-/
die Leistung vom Shelly wird immer noch als Verbrauch drauf gepackt in der Rechnung.

Bsp: Am Netz liegen 50W Bezug, PV leistet 550W -> damit sollte der Verbrauch bei 600W liegen, angezeigt wird jedoch 1150W

Wenn ich das Shelly-Skript deinstalliere, dann ist die AC-Last korrekt erfasst, jedoch sehe ich dann keinen PV-Ertrag mehr. Problem ist, dass meine Hoymiles selbst nicht mit dem Victron sprechen können und der Shelly (der die beiden WR vermessen soll) sich offenbar nicht an der richtigen Position im System platzieren lässt.


   
AntwortZitat
(@zwiebacksaege)
Vorsichtiger Stromfühler
Beigetreten: Vor 2 Jahren
Beiträge: 88
Themenstarter  

So Problem gelöst.
Im python Code kann man für das dbus Device die location angeben. Standard ist auf Null was AC in bedeutet. Auf 1 gestellt ist es an AC out und wird vorzeichenrichtig verwendet und grafisch auch korrekt dargestellt.


   
AntwortZitat
saugnapf
(@saugnapf)
Heroischer Stromgenerator
Beigetreten: Vor 2 Jahren
Beiträge: 1284
 

Super, das hilft bestimmt dem einen oder anderen auch weiter! :thumbup:

6x 300Wp = 1.8kWp an 3x EVT560 MicroInverter - MultiPlus-II GX mit 4x PylonTech US2000 (je 2,4kWh)

Hier klicken, wenn du Kollegen in deiner Umgebung finden möchtest.


   
AntwortZitat
mafe68
(@mafe68)
Autarkiekönig
Beigetreten: Vor 2 Jahren
Beiträge: 663
 

Interessant wäre auch noch vllt für einige, wo sie den Python Code finden können für den Shelly 3M auf GitHub. Vllt kann du es bei dir als Link wo rein geben solang wir auf das Forum Wiki warten wo man das ablegen könnte.

PV1: Victron ESS MultiPlus II 48/3000 | Pylontech Akku 5kW | 2880 Wp
PV2: Victron OffGrid MultiPlus II 24/3000 | TAB OPZS Akku 464Ah 11,8 kW | 10,6 kWp
Was ist Victron ESS wird hier genau erklärt!


   
AntwortZitat
(@zwiebacksaege)
Vorsichtiger Stromfühler
Beigetreten: Vor 2 Jahren
Beiträge: 88
Themenstarter  

hier...


   
AntwortZitat
mafe68
(@mafe68)
Autarkiekönig
Beigetreten: Vor 2 Jahren
Beiträge: 663
 

Wäre noch interessant ob das auch mit der Tasmota Firmware geht oder nur mit der original Shelly Firmware. Muss ich mir mal eine Testumgebung aufbauen und mir das ganze dann ansehen. Danke noch für den Link.

PV1: Victron ESS MultiPlus II 48/3000 | Pylontech Akku 5kW | 2880 Wp
PV2: Victron OffGrid MultiPlus II 24/3000 | TAB OPZS Akku 464Ah 11,8 kW | 10,6 kWp
Was ist Victron ESS wird hier genau erklärt!


   
AntwortZitat
 JUF
(@juf)
Batterielecker
Beigetreten: Vor 3 Jahren
Beiträge: 244
 

Hallo,

Ich habe meine Lösung hier mal beschrieben.
https://www.photovoltaikforum.com/thread/156974-victron-ess-mit-rasberry-steuern-ohne-gx-ohne-em24-weil-die-leistungsbilanz-scho/?postID=2617846#post2617846
Habe tasmota Stromzähler am laufen.

Grüße

BMS: JK_PB2A16S15P FW 14.20
Akku: LiFePo4 16 x 200Ah 48V
Laderegler: Victron 150/60
Inverter: Victron MultiPuls 2 48/3000/32
Solarmodule: 4 x Q.PEAK DUO-G8 355; 3 x 380W JA SOLAR; 3 x DHM-60L9(BW)-380W

Strings: 3s3p


   
AntwortZitat
(@zwiebacksaege)
Vorsichtiger Stromfühler
Beigetreten: Vor 2 Jahren
Beiträge: 88
Themenstarter  

Hallo,

Ich habe meine Lösung hier mal beschrieben.
https://www.photovoltaikforum.com/thread/156974-victron-ess-mit-rasberry-steuern-ohne-gx-ohne-em24-weil-die-leistungsbilanz-scho/?postID=2617846#post2617846
Habe tasmota Stromzähler am laufen.

Grüße

Danke für den Link
Ich will die Tage auch Mal probieren meinen Shelly auf tasmota umzustellen. Wenn ich richtig lese ändert sich nur die request Abfrage über http etwas?


   
AntwortZitat
 JUF
(@juf)
Batterielecker
Beigetreten: Vor 3 Jahren
Beiträge: 244
 

Hallo,

Ja ich habe die http api im tasmota aktiviert und die Abfrage auf http umgestellt.

BMS: JK_PB2A16S15P FW 14.20
Akku: LiFePo4 16 x 200Ah 48V
Laderegler: Victron 150/60
Inverter: Victron MultiPuls 2 48/3000/32
Solarmodule: 4 x Q.PEAK DUO-G8 355; 3 x 380W JA SOLAR; 3 x DHM-60L9(BW)-380W

Strings: 3s3p


   
AntwortZitat
(@zwiebacksaege)
Vorsichtiger Stromfühler
Beigetreten: Vor 2 Jahren
Beiträge: 88
Themenstarter  

Bei mir steigt der dbus Service nach einer Zeit immer ohne Fehlermeldung aus. Der Dienst läuft dann lt top zwar noch aber es werden weder Daten vom shelly angefragt noch an venus weiter geleitet. kennt jemand das Problem? Ich vermute dass eine kurze WLAN Unterbrechung oder tasmota restart das auslösen könnten, kann es aber nicht reproduzieren.


   
AntwortZitat
(@zwiebacksaege)
Vorsichtiger Stromfühler
Beigetreten: Vor 2 Jahren
Beiträge: 88
Themenstarter  

Da ich meine pv ja an acout1 hab ich dort nichts weiter angeschlossen ist würde ich gern versuchen den shelly weg zu rationalisieren.
kann mir zufällig jemand sagen wie ich über dbus direkt an die ac Werte komme?
Mir würde aktuell nur einfallen sie über mqtt auszulesen und dann wieder im Skript als pv Leistung einzutragen.
aber das geht doch bestimmt auch eleganter oder?


   
AntwortZitat
(@zwiebacksaege)
Vorsichtiger Stromfühler
Beigetreten: Vor 2 Jahren
Beiträge: 88
Themenstarter  

Falls es jemanden interessiert, das ShellyPV Skript ließ sich recht einfach umstricken und die nötigen Werte direkt aus dem dbus abgreifen.
Lediglich die erzeugte Energie muss nun integriert werden, da sie nicht verfügbar ist.


   
AntwortZitat
Teilen: